Customer support down
Incident Report for Hospitable.com
Resolved
This incident has been resolved.
Posted Dec 02, 2019 - 18:05 UTC
Identified
Our support service provider Intercom is currently experiencing an outage. We will be back online as soon as their outage is over!
Posted Dec 02, 2019 - 17:57 UTC
This incident affected: Supporting our customers (Live chat & email support, product tours and support documentation (on help.smartbnb.io)).